IPv6 OSPF Virtual Link Sim (Exam)

IPv6 OSPF Virtual Link Sim

We have a  small export company that has an existing enterprise network that is running IPv6 OSPFv3. Currently OSPF is configured on all routers. However, R4′s loopback address (FEC0:4:4) cannot be seen in R1′s IPv6 routing table. You are tasked with identifying the cause of this fault and implementing the needed corrective actions that uses OSPF features and does no change the current area assignments. You will know that you have corrected the fault when R4′s loopback address (FEC0:4:4) can be seen in the routing table of R1.

Another  task is that to remove area 54 virtual-link 4.4.4.4 in R4

 

 

The basic purpose of this lab is to fix an initial bad configuration.So , initially we will post a bad configuration and them we will eventually fix it.
we will do an easy copy and paste for users.



R1 Configuration:

ipv6 unicast-routing
interface Loopback1
ipv6 address FEC0:11::1/64
ipv6 ospf 1 area 0
EXIT
interface FastEthernet0/0
ipv6 address

R2 Configuration:
ipv6 unicast-routing
int loopback 1
ipv6 address fec0:22::2/64
ipv6 ospf 1 area 0
EXIT
interface FastEthernet0/0
ipv6 address FEC0:1::2/64
no shut
ipv6 ospf 1 area 0
exit
interface serial0/0
ipv6 address FEC0:2::1/64
no shut
ipv6 ospf 1 area 11
EXIT
ipv6 router ospf 1
router-id 2.2.2.2


R3 Configuration:
ipv6 unicast-routing
int loopback 1
ipv6 address fec0:33::3/64
ipv6 ospf 1area 11
EXIT
interface FastEthernet0/0
ipv6 address FEC0:3::1/64
no shut
ipv6 ospf 1area 54
exit
interface serial0/0
ipv6 address FEC0:2::2/64
no shut
ipv6 ospf 1 area 11
EXIT
ipv6 router ospf 1
router-id 3.3.3.3


We will do a wrong configuration of R4 on purpose so you can see how it's coming on the exam..

R4 Configuration:
ipv6 unicast-routing
int loopback 1
ipv6 address fec0:44::4/64
ipv6 ospf 1 area 54
EXIT
interface FastEthernet0/0
ipv6 address FEC0:3::2/64
no shut
ipv6 ospf 1 area 54
exit
ipv6 router ospf 1
router-id 4.4.4.4


 

 

 Configuration required in the exam

If we do show running-config in R2 we wont see the area 54

 But if we do show running-config on R3  we do see the area 54

 


In OSPF there is a need to connect to backbone area ( Area 0).We will configure area 11 as a transit area , so R2 and R3 will be configure  area  area ID virtual-link neighbor  ID

We will remove area 54 (step 1)and we will create a virtual link between R2(step 2) and R3 (step 3)

Step 1
R4#configure terminal
R4(config)#ipv6 router ospf 1
R4(config-rtr)#no area 54 virtual-link 3.3.3.3


 R3>enable
R3#configure terminal
R3(config)#ipv6 router ospf 1
R3(config-rtr)#no area 54 virtual-link 4.4.4.4 
R3(config-rtr)#area 11 virtual-link 2.2.2.2




 Step2 R2>enable
R2#configure terminal
R2(config)#ipv6 router ospf 1
R2(config-rtr)#area 11 virtual-link 3.3.3.3

Step 3 R4>enable 
R4#show running-config

 Verification



After configuration use command “Show IPv6 route” on R1, if you found the R4 route in routing table its mean you have done this lab successfully.







 

IPv6 OSPF Virtual Link Sim (Exam) IPv6 OSPF Virtual Link Sim  (Exam) Reviewed by victor melo on 1:30 PM Rating: 5

5 comments:

  1. Great Post ! CCNP tutorial With simple example on OSPF, Terminology, Link State, Topology, Electing DR and BDR, Discovering Routes, Calculating, Maintaining LSDB, Configuring Simple & MD5 Encrypted Authentication, Propagating Route, Configuring OSPF Commands over NBMA CCNP Tutorial & Free CCNP Test Paper.

    ReplyDelete
  2. I am glad that you like it guys..!

    ReplyDelete
  3. But am still unable to find the R4 router after doing this

    ReplyDelete
    Replies
    1. francis..I guess that you are probably are missing a step..You were supposed to find the R4 route musing the command "show IPV6 route " on R1 routing table

      Delete

Theme images by chuwy. Powered by Blogger.