Configuring EIGRP

CCNP Route labs. EIGRP Basic Configuration

EIGRP Basic Configuration -Charter 7 -Study Guide for CCNP Route

 







Objective

  1. :
     Configure EIGRP for the shown network using EIGRP AS 90. Corporate policy dictates that you must use specific wildcard masks on R2 and R3. In addition, EIGRP should be configured in such a way that it does not operate like a classful routing protocol. Finally, the BB router has a static route to 192.168.1.0/24; R2 and R3 should receive this route via EIGRP without using redistribution

  2.  R2 and R3 should have a default route pointing to the 192.168.1.0/24 network at the corporate office. No static routes can be used to accomplish this.

  3.  In order to meet security standards, EIGRP should not form neighbor relationships on any interface where other EIGRP routers do not exist.

  4.  To improve the efficiency of the remote routers R2 and R3, the corporate BB router should summarize 172.30.0.0 – 172.30.7.255 into a single network advertisement.
  5.  To best utilize available network bandwidth, the corporate BB router should perform unequal load balancing to reach the 10.1.2.0/24 network.

Exercise #5 CBT nuggets, CCNP Route     

 

 

 

         Paragraph #1

Configuration BB

Start  , enable, conf t
Asignation of the ip of each interface on R1
interface  Loopback2
ip address 172.30.2.1 255.255.255.0

interface  Loopback3
ip address 172.30.3.1 255.255.255.0
interface  Loopback4
ip address 172.30.4.1 255.255.255.0
interface  Loopback5
ip address 172.30.5.1 255.255.255.0
interface  Loopback6
ip address 172.30.6.1 255.255.255.0
interface  Loopback7
ip address 172.30.7.1 255.255.255.0
interface  Loopback8
ip address 172.30.8.1 255.255.255.0
interface  Loopback0
ip address 172.30.0.1 255.255.255.0
interface  Loopback1
ip address 172.30.1.1 255.255.255.0
Interface Serial0/0
Description Connection al R2
Bandwidth 128
Ip address 10.1.24.1 255.255.255.252    ( el “252”  viene del subneting del /30)
No shut

Interface Serial0/1
Description Connection al R3
Bandwidth 256
Ip address 10.1.34.1 255.255.255.252    ( el “252”  viene del subneting del /30)
No shut

Exit, exit
Verification of IP and conection to R1
Show ip interface  brief  
Bb#conf t
BB(config)#router eigrp 90 That number 90 is the Autonomus system and must be in all the router)
BB(config-router) #network 172.30.0.0 0.0.255.255
#No auto  ( para que no halla auto-summary)

 ( explicacion: 172.30.0.0 es class B, y 0.0.255.255 es el subnet mask…lo que estamos hacienda son 2 cosas:  A)sending hellos    a los ultimos 255.255 pues  que sean cualquiera.. no nos importa..
B)Advertising  to R2 y R3
We need to enable our SERIAL interfaces in R1
#BB(config-router)#  crtl y “z”
#BB (config-router)#network 10.1.0.0 0.0.255.255
#BB (config-router)# network 192.168.1.0  ( no mencionado hasta el min. 20
No auto-summary
Ip default-network 192.168.1.0                                           ( to connect statically)
Ip route 192.168.1.0 255.255.255.0 null0
End

# show ip protocols

(Vemos que hay eigrp 90,   y que esta routing estos networks:  10.1.0.0/16 y  el default network  172.30.0.0 que no tiene /16)
________________________________________________________________________________
Configuration of R2
Asigning the ip to the interfaces
Enable  Conf t, Hostname
Interface Serial0/0
Description Coneccion al BB
Bandwidth 128
Ip address 10.1.24.2 255.255.255.252
No shut

Interface f0/1
Description Conneccion al Switch1
Ip address 10.1.2.2 255.255.255.0
No shut 
  No auto-summary              (Nota: leer bien en la consola como esta escrito f 1/0, f 0/0, f 0/1)

Interface FastEthernet0/0
Description Conneccion al Switch2
Ip address 10.1.25.2 255.255.255.0
No shut

(Nota : 1.- ir al cuadrito de show interfaces en GNS3 que parece una paleta
            2.- despues vamos a darle un enable  de eigrp)
R2#conf t
R2(config) #router eigrp 90
R2((config-router)#do show run int fa0/0             (para ver cual es el IP especifico del fa0/0)
network 10.1.2.2 0.0.0.0
network 10.1.24.2 0.0.0.0
network 10.1.25.2 0.0.0.0
no auto                                          ( para que no halla auto-summary, se aplica no a los IP  no a los network)
end
ctrl Z
#show IP route                                                           ( para  aver las connecciones)
#Show ip eigrp neighbors     `               ( par aver la situacion de la conneccion, hasta ahora solo BB)

Explicacion de terminos de  show IP eigrp neighbors



H Handle:    The order that you have neighbors: 0 is the first neighbor
Holdtime  The order when you consider your neighbor dead ( never below 10 secs because it would               mean  you missing  hellos
SRTT :  source round trip timer ( hopw long  does it take  to get it the re and back in MS



RTO  Retrasmited time out








Q:    How many packets are in queued waiting to be send, if there is anything above 0, means the is a problem  with the bandwidth, , or a link problem
Seq Number :  La version de la base de dato que esta corriendo




Configuracion del R3

Enable, conf t y hostname R3
Interface s0/0
Description coneccion al BB
Bandwidth 256
Ip address 10.1.34.2 255.255.255.252
No shut

Interface f0/0
Description Coneccion al SW1
Ip address 10.1.2.3 255.255.255.0
No shut

Router eigrp 90
Network 10.1.2.3 0.0.0.0
Network 10.1.34.2 0.0.0.0
No auto-summary
End

#do show ip  int brief
#show ip eigrp neighbors
#show ip route
We see the  BB  and we checked that BB learned about the different routes:
BB#show ip routes
We can see that if connects to SW2  (10.1.25.0  and 10.1.2.0 using 10.1.34.0 because is the fastest  bandwidth connection)
An important command: BB#show ip eigrp topology      (17:49:mins.)
-It will show one successor : the less FD ( feasible distance) : 10.1.34.2
-It will show the slower : feasible successor, the back up
Second Paragraph
We verify the information’s  in show IP routes   in r2 if it’s receiving the static route of 192.168.1.0 of BB
The second  paragraph explain the ip default-network for 192.168.1.0,  , when it’s marked in BB with “*” means that it’s the candidate for statid route , but when you go to R2  it’s the designated static route.You can see that in #show ip routes
Third Paragraph
On R2 we need to id the interface, so we don’t want to say  hello but  advertise to other neighbors:
#show ip int brief   ( we see it’s 10.1.25.2    =   f0/1)
#router eigrp 90
#passive-interface default     
No passive-interface s0/0
No passive-interface s0/1
No auto-summary
End
We confirm at “section” eigrp :  r2#show run | s eigrp

Paragraph 4
From 0 till 7 are 8  numbers..
16  ( 15 numbers would be too much)  4 3 numbers would be too small
From 8   we go to 128,64,32,16, 8, 4,2 ,1…the 8 number would be the fifth in that order  128,192,224,240,248…   it means 248
             A.-in BB#router eigrp 90
BB#int s0/0
BB#(configif)#ip summary-address eigrp 90 172.30.0.0 255.255.248.0

            B.-Now go to R2   
R2(config-router)#do show ip route
It’s different because it got ( /21)  , that mean 8+8+5.. Belove it’s where he is learning the route 10.1.2.0, it says serial and got the double of F.D.

           C.-We found out that we need to configure in BOTH SERIAL interfaces of BB
BB(config-if)#int s0/1
BB(config-if)#ip)#ip summary-address eigrp 90 172.30.0.0 255.255.248.0

      D.-Them we go to R2 and check on  R2#show IP route  and them R3
Paragraph 5

In BB#show ip eigrp topology         We see that 10.1.34.2 is faster that 10.1.24.2

BB#(config)router eigrp 90
BB( config-router)variance2
 Crtl –z
BB#show IP eigrp topoly
Now you will see two path using A.S. 90 to 10.1.2.0 &and did load balancing to  to 10.1.25.0 as well


 _____________________________________________________________________________________________________

I hope this  page would be informative..This is basically for study purpose..
For any questions, please let me know at ohhhvictor@gmail.com
Configuring EIGRP Configuring EIGRP Reviewed by victor melo on 11:34 AM Rating: 5

No comments:

Theme images by chuwy. Powered by Blogger.