Redistribution lab for CCNP Route Exam


Redistribution of  OSPF and EIGRP lab

  

     For some reason I saw this exercise in several web sites and I couldn't make it work .I knew something was wrong..I found out that a lot of people were missing vital pieces of information.So, so far, this would be ,till now ,the only working exercise properly and fully  configured.. !

In this topology we have 4 routers., R1, R2 and R3 are running in EIGRP AS 100. While R2’s s0/2 is running in OSPF area 24, R3’s f0/0 interface is running in OSPF area 34.
 We will redistribute OSPF into EIGRP so that they can communicate with each other.Finally you will ping from R1 to Test IP 172.16.100.1 must be successful.

We will do this in 3 process:
  1. Configuration of terminals of each router
  2. Redistribution
  3. Verification and testing 


Configuration of terminals of each router

R1



*R1#enable
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#
*Mar  1 00:01:44.731: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
*Mar  1 00:01:45.731: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R1(config)#router eigrp 100
R1(config-router)#
*Mar  1 00:02:14.707: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#exit
R1(config)#
*Mar  1 00:05:54.699: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R1(config)#
*Mar  1 00:09:30.887: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.2 (Serial0/0) is up: new adjacency
R1(config)#exit


R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R1#


R2 




R2#enable
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
*Mar  1 00:01:21.583: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
*Mar  1 00:01:22.583: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#int s0/1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#
*Mar  1 00:02:20.511: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
*Mar  1 00:02:21.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2(config-if)#int s0/2

R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#ip ospf 1 area 24
R2(config-if)#no shut
R2(config-if)#
*Mar  1 00:04:19.135: %LINK-3-UPDOWN: Interface Serial0/2, changed state to up
*Mar  1 00:04:20.135: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to up
R2(config-if)#exit
R2(config)#router eigrp 100
*Mar  1 00:04:43.323: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to down
R2(config)#router eigrp 100
R2(config)#distance eigrp 90 109     (anything under 110 , that is OSPF)
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.1.0
R2(config-router)#
*Mar  1 00:05:20.075: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.1 (Serial0/0) is up: new adjacency*Mar  1 01:49:17.287: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.2.2 (Serial0/1) is up: new adjacency
*Mar  1 01:49:18.211: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.1 (Serial0/0) is up: new adjacenc

R2(config-router)# distance eigrp 90 105
R2(config-router)#
*Mar  1 00:08:23.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2(config-router)#
*Mar  1 00:10:10.199: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.2.2 (Serial0/1) is up: new adjacency
R2(config-router)#
*Mar  1 01:05:13.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to up
R2(config-router)#exit
R2(config)#exit

R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]



R3



R3#
R3#enable
R3#conf t
R3(config)#int s0/0
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#
*Mar  1 00:01:16.751: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
*Mar  1 00:01:17.751: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3(config-if)#int f0/0
R3(config-if)#ip address 192.168.4.1 255.255.255.0
R3(config-if)#no shut
*Mar  1 00:01:54.955: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:01:55.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#ip ospf 1 area 34
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.2.0
R3(config-router)#
*Mar  1 00:03:13.503: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.2.1 (Serial0/0) is up: new adjacency
R3(config-router)#
*Mar  1 01:00:01.275: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.4.2 on FastEthernet0/0 from LOADING to FULL, Loading Done

*Mar  1 01:19:23.607: %SYS-5-CONFIG_I: Configured from console by console
R3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R3#


R4


R4#enable
R4#conf t
R4(config)#int s0/0
R4(config-if)##ip address 192.168.3.2 255.255.255.0
R4(config-if)#ip ospf 1 area 24
% OSPF will not operate on this interface until IP is configured on it.
R4(config-if)#no shut

R4(config-if)#int f0/0
R4(config-if)#ip address 192.168.4.2 255.255.255.0
R4(config-if)#ip ospf 1 area 34
R4(config-if)#no shut

*Mar  1 00:53:55.223: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.4.1 on FastEthernet0/0 from LOADING to FULL, Loading Done


interface loopback 1
ip add 172.16.100.1 255.255.255.0
no shut
ip ospf 1 area 24

R4(config-if)#exit
R4(config)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]



_____________________________________________________________-


2. Configuration for the exam



Go to R2 and do a show int s0/2


In delay .. instead of doing a 20000  we will use 2000  ( divided by 10)

R2#config terminal
R2(config)# router ospf 1
R2(config-router)# redistribute eigrp 100 metric-type 1 subnets
R2(config-router)#exit
R2(config-router)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500


We will do something similar in R3 , , the F0/0 terminal

 

 


R3#config terminal
R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets
R3(config)#exit
R3(config-router)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500



In delay we will add a "0" in this scenario



Now, we dont need to do this but it's good to check the configuration

We  see in the past shot that it learns about 192.168.2.2 via s0/1  with the commands show ip route and show ip int brief

You have a well configured exercise..!No doubts for the test!

 Verification & testing of R1:
 
Show ip route on R1: You will see the all other routes if you done the correct configuration also ping from R1 to 172.16.100.1 should be successful.







Your exercise is done!

https://www.facebook.com/groups/americannetworkinstitute/


Redistribution lab for CCNP Route Exam Redistribution  lab for CCNP Route Exam Reviewed by ohhhvictor on 5:24 PM Rating: 5

No comments:

 photo imagen111.jpg
Theme images by chuwy. Powered by Blogger.